Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
SHOP ENGINE v3.1.5
29.03.2014, 16:18,
Post: #91
RE: SHOP ENGINE v3.1.5
Gdyby jeszcze ta zasada działała w Justpay to byłaby aktualizacja.

Jednak ich API nie działa na moim serwerze (żadna z 2 metod), obie wysypują błędy więc to samo może być u Ciebie. Ich API na tą chwile nie jest dopracowane, więc w najbliższym czasie nie będzie aktualizacji dla Justpay.
Odpowiedz
29.03.2014, 18:40,
Post: #92
RE: SHOP ENGINE v3.1.5
To napisz co mam odpisać firmie aby poprawili, ponieważ w tej chwili sklep całkowicie jest mi bezużyteczny. Na starej wersji API działało ze sklepem.
Odpowiedz
29.03.2014, 18:59, (Ten post był ostatnio modyfikowany: 29.03.2014, 19:00 przez XvAK.)
Post: #93
RE: SHOP ENGINE v3.1.5
Jak będę miał więcej czasu to spróbuję poprawić ich kod, w tej chwili jest bezużyteczny.

Dokładniej - u mnie na 2 hostingach nie działa xmlrpc_encode_request (a ich przykładowe skrypty nowego API wykorzystują tę funkcję standardowo). Więc nawet jeśli użyje tej metody, to na 90% polskich hostingach nie będzie działać płatność.
A ich 2 metoda - czyli gdy xmlrpc_encode_request nie działa to wykonuje skrypt pobrany z ich hostingu, który również u mnie sypie błędami Smile A tego już nie mogę poprawić.

W zasadzie mogę zaktualizować skrypt na ich nowe API, jednak to wymaga czasu a poza tym jeśli ich skrypty nie będą działać na normalnych hostingach to już tutaj nie będę miał żadnego wpływu. Po prostu to co zrobili teraz to przerost formy nad treścią, zamiast kilku linijek jest masa kodu, który i tak nie działa Smile
Odpowiedz
29.03.2014, 23:40, (Ten post był ostatnio modyfikowany: 30.03.2014, 14:02 przez daniel13362. Powód: Poprawiona ortografia)
Post: #94
RE: SHOP ENGINE v3.1.5
Kiedy w końcu będzie naprawione te API? Czekam już dwa / miesiąc, podaj termin (realny)
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości